Poznámka:
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Platí pro: Azure Stack HCI, verze 22H2 a 21H2; Windows Server 2022, Windows Server 2019, Windows Server 2016
Important
Azure Stack HCI je teď součástí Lokální Azure. Starší verze Azure Stack HCI, například 22H2, ale budou nadále odkazovat na Azure Stack HCI a neodráží změnu názvu. Další informace.
Seznamte se s plánováním nasazení infrastruktury softwarově definované sítě (SDN), včetně požadavků na hardware a software. Toto téma obsahuje požadavky na plánování pro konfiguraci fyzické a logické sítě, směrování, brány, síťový hardware a další. Zahrnuje také aspekty rozšíření infrastruktury SDN a použití postupného nasazení.
Note
SDN se nepodporuje u roztažených clusterů (s více lokalitami).
Předpoklady
Pro infrastrukturu SDN existuje několik požadavků na hardware a software, mezi které patří:
Skupiny zabezpečení a dynamická registrace DNS Musíte připravit datacentrum na nasazení síťového adaptéru, které vyžaduje sadu virtuálních počítačů. Před nasazením síťového adaptéru musíte nakonfigurovat skupiny zabezpečení a dynamickou registraci DNS.
Další informace o nasazení síťového adaptéru pro vaše datové centrum najdete v tématu Požadavky pro nasazení síťového adaptéru.
Fyzická síť. Ke konfiguraci virtuálních sítí (VLAN), směrování a protokolu BGP (Border Gateway Protocol) potřebujete přístup k fyzickým síťovým zařízením. Toto téma obsahuje pokyny pro ruční konfiguraci přepínače a také možnosti použití peeringu BGP buď na přepínačích / směrovačích 3. vrstvy, nebo na virtuálním počítači (VM) se službou Routing and Remote Access Server (RRAS).
Fyzické výpočetní hostitele. Tito hostitelé používají technologii Hyper-V a jsou potřební pro hostování infrastruktury SDN a tenantů virtuálních počítačů. Konkrétní síťový hardware je v těchto hostitelích nutný pro zajištění nejlepšího výkonu, jak je popsáno v další části.
Požadavky na hardware SDN
Tato část obsahuje požadavky na hardware pro fyzické přepínače při plánování prostředí SDN.
Přepínače a směrovače
Note
Pokud používáte přepínač certifikovaný pro Lokální Azure, bude už splňovat všechny nezbytné požadavky. Další informace naleznete v tématu Síťové přepínače pro Lokální Azure.
Při výběru fyzického přepínače a směrovače pro prostředí SDN se ujistěte, že podporuje následující sadu funkcí:
- Nastavení MTU portu přepínače (povinné)
- MTU nastaveno na >= 1674 bajtů (včetně L2-Ethernet Header)
- Protokoly L3 (povinné)
- Směrování více cest se stejnými náklady (ECMP)
- PROTOKOL ECMP založený na protokolu BGP (IETF RFC 4271)
Implementace by měly podporovat příkazy MUST v následujících standardech IETF:
- RFC 2545: Multiprotokolová rozšíření pro BGP-4 pro směrování IPv6 Inter-Domain
- RFC 4760: Multiprotocol Extensions for BGP-4
- RFC 4893: Podpora protokolu BGP pro čtyř osmičkový číselný prostor AS
- RFC 4456: Reflexe trasy protokolu BGP: Alternativa k interní síti BGP (IBGP)
- RFC 4724: Mechanismus odkladu restartování pro protokol BGP
Vyžadují se následující protokoly označování:
- VLAN – Izolace různých typů provozu
- 802.1q kufr
Následující prvky poskytují ovládání odkazu:
- Technologie QoS (Quality of Service) (PFC se vyžaduje jenom v případě použití RoCE)
- Vylepšený výběr provozu (802.1Qaz)
- Řízení toku na základě priority (PFC) (802.1p/Q a 802.1Qbb)
Následující položky poskytují dostupnost a redundanci:
- Dostupnost přepínače (povinné)
- K provádění funkcí brány se vyžaduje vysoce dostupný směrovač. Můžete to poskytnout buď pomocí vícešasiového přepínače/směrovače, nebo technologií, jako je protokol VRRP (Virtual Router Redundancy Protocol).
Konfigurace fyzické a logické sítě
Každý fyzický výpočetní hostitel vyžaduje síťové připojení prostřednictvím jednoho nebo více síťových adaptérů připojených k portu fyzického přepínače. Síť VLAN vrstvy 2 podporuje sítě rozdělené do několika logických segmentů sítě.
Tip
Použijte síť VLAN 0 pro logické sítě v režimu přístupu nebo v neoznačeném režimu.
Important
Windows Server 2016 Software Defined Networking podporuje adresování IPv4 pro podkladové a překryvné vrstvy. Protokol IPv6 se nepodporuje. Windows Server 2019 podporuje adresování IPv4 i IPv6.
Logické sítě
Tato část popisuje požadavky na plánování infrastruktury SDN pro logickou síť pro správu a logickou síť zprostředkovatele virtualizace sítě Hyper-V (HNV). Obsahuje podrobnosti o zřizování dalších logických sítí pro použití bran a nástroje pro vyrovnávání zatížení softwaru (SLB) a ukázkové síťové topologie.
Správa a poskytovatel HNV
Všichni hostitelé fyzických výpočetních prostředků musí přistupovat k logické síti pro správu a logické síti poskytovatele HNV. Pro účely plánování IP adres musí mít každý fyzický výpočetní hostitel alespoň jednu IP adresu přiřazenou z logické sítě pro správu. Síťový adaptér vyžaduje vyhrazenou IP adresu z této sítě, aby sloužila jako IP adresa REST (Representational State Transfer).
Síť poskytovatele HNV slouží jako základní fyzická síť pro provoz tenanta – východ/západ (interní-interní) provoz, sever/jih (externí-interní) provoz tenanta a výměnu informací o partnerském vztahu protokolu BGP s fyzickou sítí.
Síť zprostředkovatele HNV se vyžaduje jenom pro virtuální sítě, a ne pro logické sítě.
Tady je postup, jak síť poskytovatele HNV přiděluje IP adresy. Tento postup použijte k naplánování adresního prostoru pro síť poskytovatele HNV.
- Přidělí každému fyzickému serveru dvě IP adresy.
- Přidělí jednu IP adresu každému virtuálnímu počítači SLB MUX.
- Přidělí každému virtuálnímu počítači brány jednu IP adresu.
Server DHCP může automaticky přiřadit IP adresy pro síť pro správu nebo můžete ručně přiřadit statické IP adresy. Zásobník SDN automaticky přiřadí IP adresy pro logickou síť poskytovatele HNV jednotlivým hostitelům Hyper-V z fondu IP adres. Síťový adaptér určuje a spravuje fond IP adres.
Note
Síťový adaptér přiřadí IP adresu poskytovatele HNV fyzickému výpočetnímu hostiteli až poté, co agent hostitele síťového adaptéru přijme zásady sítě pro konkrétní virtuální počítač tenanta.
| Pokud... | Then... |
|---|---|
| Logické sítě používají sítě VLAN, | fyzický výpočetní hostitel se musí připojit k portu kmenového přepínače, který má přístup k sítím VLAN. Je důležité si uvědomit, že fyzické síťové adaptéry na hostiteli počítače nesmí mít aktivované žádné filtrování sítě VLAN. |
| Fyzický výpočetní hostitel provozuje další virtuální počítače infrastruktury, jako je řadič sítě, SLB nebo multiplexer (MUX), nebo brána. | ujistěte se, že logická síť pro správu má dostatek IP adres pro každý hostovaný virtuální počítač. Ujistěte se také, že logická síť zprostředkovatele HNV má dostatek IP adres pro přidělení každému virtuálnímu počítači infrastruktury SLB/MUX a brány. Rezervace IP adres je sice spravovaná síťovým adaptérem, ale selhání rezervace nové IP adresy kvůli nedostupnosti může mít za následek duplicitní IP adresy ve vaší síti. |
| Informace o technologii Virtualizace sítě Hyper-V (HNV), kterou můžete použít k virtualizaci sítí v nasazení Microsoft SDN, najdete v tématu Virtualizace sítě Hyper-V. |
Brány a softwarový vyrovnávač zatížení (SLB)
Abyste mohli používat brány a SLB, musíte vytvořit a zřídit další logické sítě. Ujistěte se, že pro tyto sítě získáte správné předpony IP adres, ID sítí VLAN a IP adresy brány.
| Logická síť | Description |
|---|---|
| Veřejná logická síť s virtuálními IP adresami | Logická síť veřejné virtuální IP (VIP) musí používat předpony podsítě IP, které jsou směrovatelné mimo cloudové prostředí (obvykle směrovatelné po internetu). Jedná se o front-endové IP adresy, které externí klienti používají pro přístup k prostředkům ve virtuálních sítích, včetně VIP pro front-end bránu typu site-to-site. K této síti nemusíte přiřazovat síť VLAN. Tuto síť nemusíte konfigurovat na fyzických přepínačích. Ujistěte se, že se IP adresy v této síti nepřekrývají se stávajícími IP adresami ve vaší organizaci. |
| Privátní VIP logická síť | Není nutné, aby privátní VIP logická síť byla směrovatelná mimo cloud. Důvodem je to, že ho používají jen VIP, ke kterým je možné přistupovat z interních cloudových klientů, například privátní služby. K této síti nemusíte přiřazovat síť VLAN. Tato IP adresa může být maximálně součástí sítě /22. Tuto síť nemusíte konfigurovat na fyzických přepínačích. Ujistěte se, že se IP adresy v této síti nepřekrývají se stávajícími IP adresami ve vaší organizaci. |
| Logická síť GRE VIP | cs-CZ: Síť GRE (Generic Routing Encapsulation) VIP je podsíť, která existuje výhradně k definování VIP. Virtuální IP adresy se přiřazují k virtuálním počítačům brány (gateway VMs) spuštěným na SDN síti pro připojení typu GRE site-to-site (S2S). Tuto síť nemusíte předkonfigurovat ve fyzických přepínačích nebo směrovači nebo k ní přiřadit síť VLAN. Ujistěte se, že se IP adresy v této síti nepřekrývají se stávajícími IP adresami ve vaší organizaci. |
Ukázková síťová topologie
Změňte vzorkové IP předpony podsítí a ID sítí VLAN pro vaše prostředí.
| Název sítě | Subnet | Maska | ID sítě VLAN na trunku | Brána | Rezervace (příklady) |
|---|---|---|---|---|---|
| Management | 10.184.108.0 | 24 | 7 | 10.184.108.1 | 10.184.108.1 - Směrovač 10.184.108.4 - Síťový adaptér 10.184.108.10 – Výpočetní hostitel 1 10.184.108.11 – Výpočetní server 2 10.184.108.X – Hostitel výpočetních prostředků X |
| Poskytovatel HNV | 10.10.56.0 | 23 | 11 | 10.10.56.1 | 10.10.56.1 - Směrovač 10.10.56.2 – SLB/MUX1 10.10.56.5 – Gateway1 10.10.56.6, 10.10.56.7 – Výpočetní host 1 |
| Veřejné VIP | 41.40.40.0 | 27 | Na | 41.40.40.1 | 41.40.40.2 – VIP pro veřejnost 41.40.40.3 – IPSec S2S VPN VIP |
| Privátní VIP | 20.20.20.0 | 27 | Na | 20.20.20.1 | 20.20.20.2 – Privátní VIP1 |
| GRE VIP (Důležitá osoba) | 31.30.30.0 | 24 | Na | 31.30.30.1 | 31.30.30.2 – GRE VIP1 |
Infrastruktura směrování
Informace o směrování (například další hop) pro VIP podsítě jsou inzerovány branami SLB/MUX a serverem vzdáleného přístupu (RAS) do fyzické sítě pomocí interního BGP peerování. Logické sítě VIP nemají přiřazenou síť VLAN a nejsou předem nakonfigurované v přepínači Vrstvy 2 (například přepínač Top-of-Rack).
Potřebujete vytvořit partnerský vztah protokolu BGP na směrovači, který vaše infrastruktura SDN používá k přijímání tras pro logické sítě VIP inzerované službami SLB/MUX a bránami RAS. Partnerský vztah protokolu BGP musí probíhat pouze jedním ze způsobů (z brány SLB/MUX nebo RAS k externímu partnerskému uzlu protokolu BGP). Nad první vrstvou směrování můžete použít statické trasy nebo jiný protokol dynamického směrování, například Open Shortest Path First (OSPF). Jak bylo uvedeno dříve, předpona podsítě pro logické sítě s adresou VIP opravdu musí být směrovatelná z fyzické sítě na externí BGP peer.
Služba BGP peering se obvykle konfiguruje ve spravovaném přepínači nebo směrovači jako součást síťové infrastruktury. Partnerský protokol BGP lze také nakonfigurovat na Windows Serveru s rolí RAS nainstalovanou v režimu pouze pro směrování. Směrovač BGP v síťové infrastruktuře musí být nakonfigurován tak, aby používal vlastní čísla autonomních systémů (ASN) a umožňoval připojení z ASN přiděleného komponentám SDN (SLB/MUX a brány RAS).
Musíte získat následující informace z fyzického směrovače nebo od správce sítě, který má kontrolu nad tímto směrovačem:
- Směrovač ASN
- IP adresa směrovače
Note
Čtyřbajtové ASN nejsou podporovány SLB/MUX. Musíte přidělit dvoubajtové ASN pro SLB/MUX a směrovač, ke kterému se připojuje. Sítě ASN se čtyřmi bajty můžete použít jinde ve vašem prostředí.
Vy nebo váš správce sítě musíte nakonfigurovat BGP směrovač peer, aby přijímal připojení z ASN a IP adresy nebo adresy podsítě logické sítě poskytovatele HNV, kterou používají vaše RAS Gateway a MUXy SLB.
Další informace najdete v tématu Protokol BGP (Border Gateway Protocol).
Výchozí brány
Počítače nakonfigurované pro připojení k více sítím, jako jsou fyzické hostitele, SLB/MUX a virtuální počítače brány, musí mít nakonfigurovanou jenom jednu výchozí bránu. Instalace SDN prostřednictvím Windows Admin Center, SDN Express nebo webu Azure Portal automaticky konfiguruje výchozí brány.
Pro hostitele a virtuální počítače infrastruktury použijte následující výchozí brány:
- Pro hostitele Hyper-V použijte jako výchozí bránu síť pro správu.
- Pro virtuální počítače řadiče sítě použijte síť pro správu jako výchozí bránu.
- Pro virtuální počítače SLB/MUX použijte jako výchozí bránu síť pro správu.
- Pro virtuální počítače brány použijte jako výchozí bránu síť poskytovatele HNV. To by se mělo nastavit na síťové kartě front-endu virtuálních počítačů typu brána.
Compute
Všichni hostitelé Hyper-V musí mít nainstalovaný odpovídající operační systém, musí být povolen pro Technologii Hyper-V a používají externí virtuální přepínač Hyper-V s alespoň jedním fyzickým adaptérem připojeným k logické síti pro správu. Hostitel musí být dostupný přes správní IP adresu přiřazenou k virtuálnímu síťovému adaptéru pro správu.
Můžete použít jakýkoli typ úložiště, který je kompatibilní s Technologií Hyper-V, sdíleným nebo místním.
Požadavky na výpočetní prostředky hostitele
Následující příklad ukazuje minimální požadavky na hardware a software pro čtyři fyzické hostitele používané v ukázkovém nasazení.
| Host | Požadavky na hardware | Softwarové požadavky |
|---|---|---|
| Fyzický hostitel Hyper-V | 4jádrový procesor 2,66 GHz 32 GB paměti RAM 300 GB místa na disku Fyzický síťový adaptér o velikosti 1 Gb/s (nebo rychlejší) |
Operační systém: Jak je definováno v "Platí pro" na začátku tohoto tématu. Nainstalovaná role Hyper-V |
Požadavky na roli virtuálních počítačů infrastruktury SDN
Níže jsou uvedeny požadavky na role virtuálních počítačů.
| Úloha | Požadavky na vCPU | Požadavky na paměť | Požadavky na disk |
|---|---|---|---|
| Síťový adaptér (tři uzly) | 4 virtuální procesory | Minimálně 4 GB (Doporučuje se 8 GB) |
75 GB pro jednotku operačního systému |
| SLB/MUX (tři uzly) | 8 vCPUů | Doporučeno 8 GB | 75 GB pro jednotku operačního systému |
| Brána RAS jedna skupina tří uzlů brány, dvě aktivní, jedna pasivní) |
8 vCPUů | Doporučeno 8 GB | 75 GB pro jednotku operačního systému |
Pokud pro nasazení používáte nástroj System Center – Virtual Machine Manager (VMM), jsou zapotřebí další prostředky infrastruktury VM pro VMM i pro další infrastrukturu mimo SDN. Další informace najdete v tématu Požadavky na systém pro nástroj System Center Virtual Machine Manager.
Rozšíření infrastruktury
Velikost a požadavky na prostředky pro vaši infrastrukturu závisí na pracovním zatížení virtuálních počítačů, které plánujete hostovat. Požadavky na procesor, paměť a disky pro virtuální počítače infrastruktury (například síťový adaptér, SLB, brána atd.) jsou definovány v předchozí tabulce. Podle potřeby můžete přidat další virtuální počítače infrastruktury pro škálování. Všechny klientské virtuální počítače spuštěné na hostitelích Hyper-V ale mají vlastní požadavky na procesor, paměť a disk, které je potřeba zvážit.
Když virtuální počítače pro pracovní zátěže nájemníků začnou spotřebovávat příliš mnoho prostředků na fyzických hostitelích Hyper-V, můžete svou infrastrukturu rozšířit přidáním dalších fyzických hostitelů. Pomocí skriptů Windows Admin Center, VMM nebo PowerShellu můžete vytvářet nové prostředky serveru prostřednictvím síťového adaptéru. Metoda, která se má použít, závisí na tom, jak jste původně nasadili infrastrukturu. Pokud potřebujete přidat další IP adresy pro síť poskytovatele HNV, můžete vytvořit nové logické podsítě (s odpovídajícími fondy IP adres), které můžou hostitelé používat.
Postupné nasazení
Na základě vašich požadavků možná budete muset nasadit podmnožinu infrastruktury SDN. Pokud například chcete hostovat jenom úlohy zákazníků ve vašem datacentru a externí komunikace není nutná, můžete nasadit síťový adaptér a přeskočit nasazení virtuálních počítačů SLB/MUX a bran. Následující část popisuje požadavky na infrastrukturu síťových funkcí pro postupné nasazení infrastruktury SDN.
| Feature | Požadavky na nasazení | Požadavky na síť |
|---|---|---|
| Správa logické sítě Skupiny zabezpečení sítě (NSG) (pro síť založenou na síti VLAN) Technologie QoS (Quality of Service) (pro sítě založené na síti VLAN) |
Síťový kontrolér | None |
| Virtuální sítě Směrování definované uživatelem ACL (pro virtuální síť) Šifrované podsítě QoS (pro virtuální sítě) Propojení virtuálních sítí |
Síťový kontrolér | HNV PA VLAN, Podsíť, Směrovač |
| Příchozí/odchozí překlad síťových adres (NAT) Vyrovnávání zatížení |
Síťový kontrolér SLB/MUX |
Protokol BGP v síti HNV PA Privátní a veřejné podsítě VIP |
| Připojení brány GRE | Síťový kontrolér SLB/MUX Brána |
Protokol BGP v síti HNV PA Privátní a veřejné podsítě VIP Podsíť GRE VIP |
| Připojení brány IPSec | Síťový kontrolér SLB/MUX Brána |
Protokol BGP v síti HNV PA Privátní a veřejné podsítě VIP |
| Připojení brány L3 | Síťový kontrolér SLB/MUX Brána |
Protokol BGP v síti HNV PA Privátní a veřejné podsítě VIP VLAN pro nájemce, podsíť, směrovač Volitelný protokol BGP v síti VLAN tenanta |
Další kroky
Související informace najdete také: